пятница, 9 декабря 2011 г.

XML::Parser error

Проблема: всплывающая ошибка error: XML::Parser perl module is required for intltool

1) Уточняем ошибку, запустив
#/usr/bin/perl -e "require XML::Parser" 
*Подробности см по первой ссылке*



2) Если таки не может найти модуль (возвращает что-то типа)
Can't locate XML/Parser.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at -e line 1.
тогда заходим через рут
#su - 

3) Запускаем CPAN
perl -e shell -MCPAN


4) Устанавливаем необходимый модуль
install XML::Parser

enjoy



Помогли:
http://www.karakas-online.de/
http://www.linuxquestions.org/

Комментариев нет:

Отправить комментарий